[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#753589: systemd: missing pre-dependencies for runlevel(8) etc.

Simon McVittie <smcv@debian.org> writes:

> Expanded dependency tree:

> libc6 is already quasi-Essential, via e.g. coreutils
> libdbus-1-3 Depends: libc6 (>= 2.17)
> libgcrypt11 Depends: libc6 (>= 2.15)
> libgcrypt11 Depends: libgpg-error0 (>= 1.10), already satisfied in stable
> libgpg-error0 Depends: libc6 (>= 2.14)
> liblzma5 Depends: libc6 (>= 2.4), already satisfied in stable
> libselinux1 is already quasi-Essential, via coreutils
> libsystemd-daemon0 Depends: libc6 (>= 2.8), already satisfied in stable

liblzma5 is already quasi-Essential since dpkg depends on it.

Libraries are generally fairly easy to make essential, if I recall
correctly, so I don't think the burden here is very high.  It makes sense
to me to go ahead and do this.  (Simon knows this, but for others who may
be wondering, note that libraries themselves are not tagged essential in
the package metadata because that just makes transitions harder.  So this
would promote all of these to quasi-essential, but not tag them with
Essential: yes.)

The other common objection is package size, so, for the record:

libdbus-1-3         410KB
libgcrypt11         646KB
libgpg-error0       413KB
libsystemd-daemon0   39KB

so this would add about 1.5MB to essential.

Russ Allbery (rra@debian.org)               <http://www.eyrie.org/~eagle/>

Reply to: