[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RFH: sane-backends FTBFS on buildds, but not in pbuilder


I sponsored a new version of sane-backends today which Mark Buda (CC)
has recently adopted. He has imported the latest upstream version 1.0.24
and fixed some lintian issues.

Unfortunately, this package currently fails to build on the buildds
while it builds fine when building in a pbuilder environment [1].

The builds fails during dh_installdocs which previously worked fine,
the debian/rules file is identical for version 1.0.23-3 and 1.0.24-1,
so the issue must lie somewhere else.

I have already tried removing debhelper's option "--parallel" (since
this resulted in similar issues on some packages before) as well as
changing the source path for the affected file "sane.ps" from
"debian/libsane-common/usr/share/doc/libsane/sane.ps" to
"debian/usr/share/doc/libsane/sane.ps", yet this doesn't fix the issue.

I have used my Launchpad PPA for these tests [2], but without luck so

Anyone has a clue what could be wrong? I can't really wrap my head
around the fact that it builds fine in a pbuilder environment but
not on the actual buildds.

Any help is highly appreciated!



> [1] https://buildd.debian.org/status/package.php?p=sane-backends
> [2] https://launchpad.net/~glaubitz/+archive/misc/+packages

 .''`.  John Paul Adrian Glaubitz
: :' :  Debian Developer - glaubitz@debian.org
`. `'   Freie Universitaet Berlin - glaubitz@physik.fu-berlin.de
  `-    GPG: 62FF 8A75 84E0 2956 9546  0006 7426 3B37 F5B5 F913

Reply to: