[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#719673: ITP: needrestart -- needrestart checks which daemons need to be restarted after library upgrades

On Tue, Oct 15, 2013 at 12:21 AM, Matthias Klumpp  wrote:

> It just checks that - I wanted it to look for upload-priorities in
> Debian changelogs some time ago, but doing that was just way too slow.

Higher upload priorities doesn't indicate a security fix. It could be
an RC bug fix or certain people using higher priority without that
being appropriate.

> That would be a nice feature to have! I think when this features was
> revised some time ago, these options where not yet available.
> It would just have to be fast enough, because PK needs the security
> status almost immediately (otherwise the updater UI will have very
> long loading times).

debsecan and the security tracker has been around since before the
etch release, so I guess it existed before PK. As to speed, it could
update the debsecan data before every apt-get update.




Reply to: