[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#719673: ITP: needrestart -- needrestart checks which daemons need to be restarted after library upgrades


2013/8/22 Paul Wise <pabs@debian.org>:
> On Thu, Aug 22, 2013 at 11:17 AM, Matthias Klumpp wrote:
>> PackageKit can do that ;-) It has a plugin to check for shared
>> libraries in use, I just haven't tested in yet. It should show the
>> names of services which need to be restarted after a security update.
> Cool.
>> This info is at least shown on the command line (and only for security updates).
> How does it know if an update fixes a security issue? Just checking if
> it comes from security.d.o would not be enough since updates to
> unstable often fix security issues.
It just checks that - I wanted it to look for upload-priorities in
Debian changelogs some time ago, but doing that was just way too slow.

> I guess it uses the
> debsecan/security-tracker data?
That would be a nice feature to have! I think when this features was
revised some time ago, these options where not yet available.
It would just have to be fast enough, because PK needs the security
status almost immediately (otherwise the updater UI will have very
long loading times).

Reply to: