[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

update-menus silently failing with Gnome?

I've been trying to create menu items for postbooks and
postbooks-updater, for example:


is a debian/menu file containing:

?package(postbooks-updater):needs="X11" \
   section="Applications/Office" \
   title="PostBooks Updater" \
   command="postbooks-updater" \

The file is installed to /usr/share/menu/postbooks-updater

The xpm file exists (it is installed by another package)

I can see that update-menus is run during the dpkg install and I tried
running it again manually.

I can even find the .desktop file for Gnome after update-menus has run,
it looks OK

However, the item just doesn't appear in the menu, even after logging
out and rebooting

I also tried looking in the menu editor to see if it was disabled, but
it is not there either

The update-menus -v output doesn't give any clues

Are there some extra steps required to make a working menu item?  Could
they be added to http://www.debian.org/doc/packaging-manuals/menu.html/

Reply to: