[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: AGPLv3 Compliance and Debian Users

On Thursday, July 11, 2013 12:26:47 PM Joachim Breitner wrote:
> Hi,
> Am Donnerstag, den 11.07.2013, 17:48 +0800 schrieb Paul Wise:
> > On Thu, Jul 11, 2013 at 5:41 PM, Lars Meyser wrote:
> > > This is also my personal reading of the license, I would like to hear
> > > others opinions before I start filing bugs.
> > 
> > Perhaps you missed "if you modify the Program" in item "13. Remote
> > Network Interaction;" of the AGPL?
> nevertheless it would be good if AGPL programs in general, and
> especially as packaged in Debian, would simply also install a tarball of
> the (patched) sources and have a download link in the program, so that
> the user has do not worry about this at all.

The trick here is it's not just packages explicitly licensed with the AGPL 
that are affected.  It's also packages that have an AGPL compatible license 
that link against anything that's an AGPL library (the specific reason libdb is 
an issue), so if we end up with AGPL libraries, this could be widespread.

Scott K

Attachment: signature.asc
Description: This is a digitally signed message part.

Reply to: