[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

gfortran: binNMU needed?


With gcc-4.8,  gfortran has (again) changed the format for its .mod files.
The result of this is that it is no longer possible to use fortran
modules in sid,
in at least 2 packages:

Fatal Error: Cannot read module file 'grib_api.mod' opened at (1),
because it was created by a different version of GNU Fortran

Known packages: netcdf, grib-api
I think these can be fixed with a simple binNMU; is one planned?

More long-term, is there anything we can do about this? A more stable
version of the 'mod' file?

Best regards

Alastair McKinstry  , <alastair@sceal.ie> , <mckinstry@debian.org>  http://diaspora.sceal.ie/u/amckinstry
Anyone who believes exponential growth can go on forever in a finite world is either a madman or an economist - Kenneth Boulter, Economist.

Reply to: