[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Update on R 3.0.0 migration (Was: R 3.0.0 and required rebuilds of all reverse Depends: of R)

On 07.04.2013 03:07, Julian Gilbey wrote:
> Ah, thanks Chris, I wasn't aware of that!  But then it seems to me
> that the correct lines should be:
> Build-Depends: ..., r-base-dev, ...
> [...]
> Depends: ..., ${R:Depends}, ...
> as the source package is *not* dependent upon the R version, only the
> binary package resulting from it; this will aid any backporters, for
> example.
No, you have to Build-Depend on the minimal R version your package needs.
A (probably bad) example: sactterelot3d needs R >= 2.7.0 so my Build-Depends is:

Build-Depends: debhelper (>= 9), cdbs, r-base-dev (>= 2.7.0)


Reply to: