[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: missing libgl1-mesa-dri in upgrades

On 04/01/2013 09:59 PM, Daniel Pocock wrote:
Agreed, but that doesn't complete the picture, as libgl1-mesa-glx
doesn't depend on libgl1-mesa-dri:

$ apt-cache depends libgl1-mesa-glx
     Recommends: libgl1-mesa-dri

Well, "Recommends" are installed by default, aren't they? However, I'm not sure why it shouldn't be depending on either "libgl1-mesa-dri" or "libgl1-mesa-swx11" here. I mean, MESA doesn't work without either of these, does it?

Either empathy or libclutter probably need to generate a popup error
window in this situation, if the error only appears in a console then it
will leave users with a bad impression of any impacted binary.
Generating such an error is independent of making sure the dependency is

No, I don't think there should be a popup. Someone should just fix the dependencies.

Also, have you tried running Empathy on a non-compositing window manager
when libgl1-mesa-dri is not installed?

I'm happy to try that, can you propose which window manager I should
try?  I know fvwm quite well and don't mind installing that.

Yeah, fvwm doesn't really do any compositing :).


 .''`.  John Paul Adrian Glaubitz
: :' :  Debian Developer - glaubitz@debian.org
`. `'   Freie Universitaet Berlin - glaubitz@physik.fu-berlin.de
  `-    GPG: 62FF 8A75 84E0 2956 9546  0006 7426 3B37 F5B5 F913

Reply to: