[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: R 3.0.0 and required rebuilds of all reverse Depends: of R

On 31 March 2013 at 19:41, Ansgar Burchardt wrote:
| Dirk Eddelbuettel <edd@debian.org> writes:
| > On 31 March 2013 at 19:12, Ansgar Burchardt wrote:
| > | However the binaries seem to claim they would also work with the newer R
| > | versions? I looked at r-cran-rsymphony and it has
| > |   Depends: [...], r-base-core (>= 2.14.1)
| >
| > You looked at the code from before the update of that package:
| >
| >   Package: r-cran-rsymphony
| >   Architecture: any
| >   Depends: ${shlibs:Depends}, ${R:Depends}
| >
| > leading to 
| >
| >   edd@max:~$ dpkg -f /var/cache/pbuilder/result/r-cran-rsymphony_0.1-15-2_i386.deb |grep Depends
| >   Depends: libatlas3-base, libc6 (>= 2.1.3), libgcc1 (>= 1:4.1.1), \
| >   libgfortran3 (>= 4.3), libquadmath0 (>= 4.6), libstdc++6 (>= 4.4.0), \
| >   r-base-core (>= 3.0.0~20130330-1) 
| >   edd@max:~$ 
| >
| > | which would still be satisfied by r-base-core 3.0.0~20130330-1...
| >
| > Not an issue as seen above.
| That just means you cannot use the new r-cran-rsymphony with the old
| r-base-core. But it looks like you can use the *old* r-cran-rsymphony
| with the *new* r-base-core, although you said that a rebuild is required
| (and thus this combination shouldn't be allowed by the dependencies).

No, sorry, that is precisely where the restriction comes in.  Here is a log
from my laptop, running the R 3.0.0 pre-release and trying to load a non-CRAN
package (of mine, at R-Forge) built with an earlier version:

Script started on Sun 31 Mar 2013 12:45:41 PM CDT
edd@don:~$ R

R version 3.0.0 RC (2013-03-27 r62427) -- "Masked Marvel"
Copyright (C) 2013 The R Foundation for Statistical Computing
Platform: i686-pc-linux-gnu (32-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

  Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

R> library(earthmovdist)
Error: package ‘earthmovdist’ was built before R 3.0.0: please re-install it
R> q()
Save workspace image? [y/n/c]: n
edd@don:~$ exit

Script done on Sun 31 Mar 2013 12:46:03 PM CDT

In the 10+ years that I maintained the R package, this is only the third
forced rebuild.  These happen rarely, but when they happen they are imposed
by R itself.

We really need to rebuild all packages for R.  And no, I of course do not
imply that these would slide into the next release. 


Dirk Eddelbuettel | edd@debian.org | http://dirk.eddelbuettel.com

Reply to: