[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#698209: ITP: librarian-puppet -- a bundler for your puppet infrastructure

Package: wnpp
Severity: wishlist
Owner: Stig Sandbeck Mathisen <ssm@debian.org>

* Package name    : librarian-puppet
  Version         : 0.9.7
  Upstream Author : Tim Sharpe <tim@github.com>
* URL             : https://github.com/rodjek/librarian-puppet
* License         : MIT
  Programming Lang: Ruby
  Description     : a bundler for your puppet infrastructure

Librarian-puppet is a bundler for your puppet infrastructure. You can use
librarian-puppet to manage the puppet modules your infrastructure depends on.
It is based on Librarian, a framework for writing bundlers, which are tools
that resolve, fetch, install, and isolate a project's dependencies.

Librarian-puppet manages your modules/ directory for you based on your
Puppetfile. Your Puppetfile becomes the authoritative source for what modules
you require and at what version, tag or branch.

Once using Librarian-puppet you should not modify the contents of your modules
directory. The individual modules' repos should be updated, tagged with a new
release and the version bumped in your Puppetfile.

Reply to: