[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Packaging MATE for Debian

Le lundi 03 décembre 2012 à 20:28 +0100, Stefano Karapetsas a écrit : 
> That repository contains the current stable MATE. The repository with 
> develpment MATE packages, without "obsolete" libraries, is
> deb http://dev.mate-desktop.org/debian wheezy main
> Our github repo with debian folders, in master branch, is without 
> removed packages too.

This still includes seemingly useless forks of:
- libwnck, still in Debian
- libgnome-keyring (no GTK3 dependency)
- libnotify: only trivial API changes between the forked version and
   the current one
- libgnome-desktop (still in Debian)
- metacity (here to stay)
- libgnome-menus (you could split only the menu editor and the
- gnome-doc-utils (here to stay)

Also having an old fork of libgweather without sharing the data is
completely absurd.

On a related but less important matter: unless they have been pushed
upstream, you might also want to add the patches that we had in Debian’s
GNOME 2 that fix long-standing bugs – I’d quote the file manager’s fixed
width columns, which I find almost unusable without the patch, if I had
to choose one.

 .''`.      Josselin Mouette
: :' :
`. `'

Reply to: