[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Policy released

Christian PERRIER <bubulle@debian.org> writes:

> Thanks again and again for the great work maintaining the policy (and
> lintian as well).

> Given the quite important change of making build-{arch,indep} targets
> mandatory, wouldn't have been better to use something like 3.10.1 or
> anything clearly saying "hey, there are not only minor changes here"?

> (not sure wheter 3.10.1 > 3.9.4 but you probably get the point)

Hm.  You might be right; I didn't really think about it.

I will note, though, that I don't think this affects as many packages as
one might think.  If you're using dh with a wildcard rule, you get this
for free.  If you're using CDBS, I believe you already got this for free.
Most of the templates have included those targets for a long time, so
older debhelper packages already supported them.

Also, since dpkg has a workaround for this that will probably be
maintained for quite some time, there's no particular rush.

But yeah, in retrospect, with that and the symbols rewrite, this probably
should have been  Usually I'm better about incrementing version
numbers aggressively than that!

Well, I'll use that version once we get the multiarch changes in for sure.

Russ Allbery (rra@debian.org)               <http://www.eyrie.org/~eagle/>

Reply to: