[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

packages, uses dbconfig-common and mysql/postgresql installation order.


bacula-director-pgsql package has a bug #605449 - package can be setup
after postgresql installation and dbconfig-common fail to configure

I try to see, how this problem solved in other packages and can't find
answer. For example, roundcube-mysql, cacti, drupal6 not affected this
bug, but roundcube-pgsql, bacula-director-pgsql, bacula-director-mysql,
jffnms - affected.

This is can be simply checked by one of next commands:

  apt-get install -s bacula-director-pgsql postgresql
  apt-get install -s bacula-director-mysql mysql-server

This is related to apt-get  package installation order algorithm and i
don't know how to force mysql and potgresql configuration before
package configuration.

How can be this problem solved?

with best regards,
Alexander Golovko
email: alexandro@ankalagon.ru
xmpp: alexandro@ankalagon.ru

Attachment: signature.asc
Description: PGP signature

Reply to: