[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Stuff from /bin, /sbin, /lib depending on /usr/lib libraries

2012/8/31 Simon McVittie wrote:

>> thus it reduces flexibility, breaking use cases, that were working before.
> Please name them.

I was thinking about lots of custom mount options that were easy to set up
and were working for decades with normal root partition, but will now need
tricky hacks to adopt them for initramfs.

But there're more:
* ability to easily edit content of root partition and put some additional
  software to mount /usr (much easier than making changes to initramfs)
* ability to boot with separate /usr without initramfs (people still use that)
* recover from epic disaster
* log in locally as root and check/fix things having non-mountable usr

There're some minor issues, not that important, but still:
* larger initramfs adds problems for embedded systems
* update of binaries in root partition does not update binaries in initramfs

You may think that none of that really needed. "You don't need it" is a very
popular argument in such cases. But it never works, because I can answer that
computers and mobile phones are not really needed as well, mankind existed
without them for thousands of years. But it does not mean that we should
throw them out of window. We already had all these things before, it's
pointless to throw them out for nothing.

> "The ability to mount my /usr requires user interaction via a UI in /usr"
> doesn't count, because it has never worked, and is logically impossible.

Yes, that's what I'm talking about. It was not solved before, and it's still
not solved. New initramfs approach solves nothing. It just turns one problem
into another one, requires additional work and adds slots for new bugs.

> If a filesystem is not on the critical path to boot to the point where
> you can get the prerequisites for mounting filesystems, you don't need
> to mount it from the initramfs. (For instance, /srv isn't needed until
> later.)

You can't be sure about that. It could be that on some system the stuff needed
to mount /usr was on /srv partition. And it worked because /srv was put before
/usr in /etc/fstab. In "historical approach" it works, but not in
"initramfs approach".


Reply to: