[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#677582: gcc-4.4-base: upgrade problems since removal of gcj-4.4

On Fri, Jun 15, 2012 at 03:10:16 +0200, Andreas Beckmann wrote:

> during piuparts dist-upgrade tests I noticed problems upgrading from
> squeeze if gcj-4.4 is installed. gcj-4.4 was recently removed from sid
> and testing and there is no clean upgrade path and apt decides to keep
> gcc-4.4-base at an old version instead of removing the obsolete gcj-4.4
> packages. Because of
>   Package: gcc-4.4-base
>   Breaks: gcj-4.4-base (<< 4.4.6-9~)
> and
>   $ rmadison gcj-4.4-base
>    gcj-4.4-base | 4.4.5-2 | squeeze
> the old version has to be removed.
Does it make any difference if you change the Breaks to Conflicts?


Attachment: signature.asc
Description: Digital signature

Reply to: