[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: DEP-8 extension proposal: Add source package header

Hello Stefan,

Stefano Zacchiroli [2012-06-13 23:42 +0200]:
> [ Adding autopkgtest-devel to recipients, where I've also just bounced
>   your mail. If you're interested in this topic, please consider
>   subscribing to that, very low traffic, list. ]

Subscribed. Thanks for bouncing it, as I cannot mail Ian directly
(his MTA rejects my mail server).

> Oh, that's nice, thanks! Is the test execution environment something
> that can easily deployed elsewhere?

Not directly yet, but we are planning to. From bottom up it's
autopkgtest running in a VM with a daily development release install
triggered by Jenkins jobs:


I'm not sure whether the scripts to do the back and forth
setup/reporting are in some public branch, Jean-Baptiste would know.

Locally I test with something like

  sudo adt-run foo.dsc --- adt-virt-null

which is essentially what these Jenkins jobs do as well.

> I'm also curious about the implementation: do you actually use
> autopkgtest as low level test runner for Jenkins integration or...?

We do. We had to fix a number of bugs there, they just recently were
uploaded to Debian as well (thanks Ian).

> As a temporary alternative to a hardcoded list, Stuart's proposal to use
> Contents-source.gz is clearly better.

Right, that would do as well. However, I don't see this on


? We don't build a Contents-source.gz on Ubuntu either.

> As long as it stays as a XS-* header (which, for the history, it's also
> how Vcs-* fields came into existence), no tool change is needed.

Not needed, but it would be nice if dpkg-source could just add it
automatically, so that developers don't need to care about it.

> We should just agree upon a name. But if we want to have hopes to
> promote it to something more official, I think it should rather be
> independent from autopkgtest.

Fully agree. It should be specific to this standard (developed as
DEP-8), which does not have a name yet apparently?

> How about something like "XS-Testsuite: runtime", where the key is
> actually a space separate list of values values.  Right now only
> "runtime" [1] makes sense, but others might appear in the future.

Perhaps "system-integration" or "install"/"installed" (as opposed to
"build" test which are run during package build from debian/rules)
might be clearer?

I saw that coming: There would be little dispute about adding a
header, but lots of difficulty to find a good name. :-) Perhaps we
should think about an actual name for DEP-8 first (similar to what we
had with DEP-5 -> "copyright 1.0 format"), and then use an
abbreviation of that for the XS-Testsuite: value?



Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)

Attachment: signature.asc
Description: Digital signature

Reply to: