[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Conflicting deps: python (>= 2.6.6), python (<< 2.6)

Hello, list,

I was trying to compile xen-utils-4.1 on Squeeze:
$ apt-get source -t testing xen-utils-4.1
$ pbuilder --build xen_4.1.2-2.dsc
$ dpkg -I /var/cache/pbuilder/result/xen-utils-4.1_4.1.2-2_amd64.deb
 Depends: e2fslibs (>= 1.41.0), libc6 (>= 2.7), libgnutls26 (>=
 2.7.14-0), libncurses5 (>= 5.7+20100313), libpci3 (>= 1:3.1.7),
 libuuid1 (>= 2.16), libxen-4.1 (>= 4.1.2), libxenstore3.0 (>=
 4.0.1~rc4), zlib1g (>= 1:1.1.4), python (>= 2.6.6-3+squeeze3~), python
 (<< 2.6), xen-utils-common (>= 3.4.2-4)

As we can see, there is a conflicting dependency:
python (>= 2.6.6-3+squeeze3~), python (<< 2.6)

How did this happen? xen-4.1.2/debian/control file looks fine IMHO:
Package: xen-utils-4.1
Architecture: amd64 i386
Provides: xen-utils
Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends}, xen-utils-common (>= 3.4.2-4)
Recommends: bridge-utils, libc6-xen [i386], xen-hypervisor-4.1, qemu-keymaps, qemu-utils

This is the complete build log (warning: 1.7M):

dpkg version Chrooted pbuild is *stable*. It needed ipxe, so
had to set up a local apt repository and provide it beforehand.

If there is any more I can provide, please let me know.

Motiejus Jakštys

Reply to: