[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Build error form Ubuntu regarding xz compression

On Wed, Oct 19, 2011 at 02:09:47PM +0200, olivier sallou wrote:
> I received an email error from Ubuntu regarding build of a package
> (extracted from debian):

I'm sorry you received this error; this is a Launchpad bug
(https://bugs.launchpad.net/launchpad/+bug/876594).  We obviously don't
want to spam Debian developers with Ubuntu upload errors.

> Rejected:
> Require Pre-Depends: dpkg (>= 1.15.6) when using xz compression.
> Require Pre-Depends: dpkg (>= 1.15.6) when using xz compression.
> Package indeed uses xz compression, but do you know what I should put
> in package for this on debian side?
> Should I add in debian control a pre-depends on dpkg as said in message?

Didier has already answered this.  Making such a change is indeed
harmless in Debian.

I would also add that I've been fixing all these in Ubuntu as we go
along (in changes that we'll be able to discard after Ubuntu 12.04 LTS)
on the grounds that it's basically our fault for not having managed to
get dpkg 1.15.6 into our last LTS release and thus we should cope with
the fallout; so while I certainly wouldn't say no if Debian developers
want to add the appropriate Pre-Depends, we'll cope if you don't.


Colin Watson                                       [cjwatson@ubuntu.com]

Reply to: