[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: A short question about apt-get build-dep

Svante Signell, le Fri 19 Aug 2011 11:07:04 +0200, a écrit :
> When issuing 'apt-get build-dep opensp' openjade1.3 is installed. The
> problem is that opensp does not build with that version.

You mean that you get the thread assertion issue?

> However it builds OK with openjade (currently 1.4devel1-20).

Which could explain why it worked for me: I had installed openjade, not

> Does changing the order prefer openjade before openjade1.3?

But are you implying that you'd want to submit that patch to the
maintainer? I guess that if the order is that one, there's a reason.

> Or would adding openjade1.3 [!hurd-i386] be a better solution.

The better solution would be to actually fix the issue, not hide it.

Anyway, to fix your local issue, simply install openjade by hand, and
apt-get build-dep will be fine with it.


Reply to: