[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

A short question about apt-get build-dep


I have a slight problem when building opensp for GNU/Hurd. In the
build-dep list for opensp we have:

apt-cache showsrc opensp|grep Build-Depends
Build-Depends: debhelper (>> 7.0.0), dh-buildinfo, xmlto, poppler-utils,
openjade1.3 | openjade, jadetex, docbook-dsssl

When issuing 'apt-get build-dep opensp' openjade1.3 is installed. The
problem is that opensp does not build with that version. However it
builds OK with openjade (currently 1.4devel1-20).

Does changing the order prefer openjade before openjade1.3? Or would
adding openjade1.3 [!hurd-i386] be a better solution.

I edited the Build-Depends entry of opensp in
as a test but all the time openjade1.3 was selected.

Doesn't apt-get build-dep read that file, or what is wrong with my

Reply to: