[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: packaging-dev 0.1 in unstable

[Benjamin Drung]
> packaging-dev 0.1 is now available in Debian unstable. If you think that
> it misses a dependency or recommends, file a bug or discuss it on this
> mailing list. I like to see these kind of discussions:
> A: I am new to packaging. How do I get started?
> B: Install packaging-dev and then ...!

More power to you and your users, but if you're _truly_ new to Debian
packaging, installing the appropriate packges is the very very very
very very least of your concerns.  I would see a "Install packaging-dev
and then..." answer as equivalent to those tutorials that tell you to
"./configure && make && sudo make install" as a single line to paste
into your shell.  Sure, when it works it works, but if the goal is to
convey any sort of understanding of what one is doing ... it really
doesn't.  Better, IMO, to know what tools you need and why, not just
"install packaging-dev".
Peter Samuelson | org-tld!p12n!peter | http://p12n.org/

Reply to: