[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ruby changes for Wheezy

Le samedi 05 mars 2011 à 00:22 +0100, Piotr Ożarowski a écrit : 
> > Breaks: python (>= 2.8), python (<< 2.5)
> yeah, that's to avoid bug reports when someone will try to use this
> package with (default) python 2.4 or python 2.8 (which will NEVER be
> released, BTW). dh_python2 will create similar dependencies to those
> generated by dh_py{central,support} if Breaks: ${python:Breaks} is
> missing in debian/control (I like Breaks because... that's what
> Breaks is for)

You might “like” Breaks, but this:
    Depends: python
    Breaks: python (>= 2.8), python (<< 2.5)
has the same semantics as:
    Depends: python (>= 2.5), python (<< 2.8)
except that APT deals *much* better with Depends than it does with

What is the point of doing that?

 .''`.      Josselin Mouette
: :' :
`. `'  “If you behave this way because you are blackmailed by someone,
  `-    […] I will see what I can do for you.”  -- Jörg Schilling

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: