[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: binNMU for Arch: all packages.

On 2011-01-15, Stéphane Glondu <glondu@debian.org> wrote:
> Le 15/01/2011 13:23, Julien Cristau a écrit :
>> Package: foo
>> Architecture: all
>> Package: bar
>> Architecture: any
>> Depends: foo (= ${source:Version})
>> If ${source:Version} is not version(arch:all) you've got yourself an
>> uninstallable package.  If ${source:Version} is not version(source)
>> things become slightly confusing.  Again.  We've had enough of that with
>> ${Source-Version}.  And it'll probably break some other stuff as well.
> Well... Someone could also make an arch:any package depend on the
> ${source:Version} of another arch:any package, if he wants to shoot
> hisself in the foot. It doesn't prevents binNMUs of arch:any packages.

You do realize that it's common to do the source:Version dependency stuff in
arch:all packages, right?  That kind of polemics you just raised doesn't seem
helpful to me.

Kind regards
Philipp Kern

Reply to: