[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Oops: I broke the lenny --> squeeze update


I just received notice (bug 603579) that upgrade lenny to squeeze will
break if a boost package containing an "rtupdate" script is installed.
In stable there are four such packages:



The issue is that the rtupdate script in stable only recognizes python
2.4 and python 2.5, and dies if any other version is supplied.
Squeeze python default is 2.6 and so this blocks the upgrade of
python, which is very bad.

The rtupdate script has since been changed (in unstable) to avoid this
problem, but I'm not sure what can be done for stable users other than
recommending to purge the above four packages prior to upgrade.  Is
there any way to do this automatically?

Brown-paper-bagged-ly yours,

Attachment: signature.asc
Description: Digital signature

Reply to: