[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dkms needs a pre-depends entry (Policy 3.5)

On 07/20/2010 10:04 PM, Russ Allbery wrote:
> Bernd Zeimetz <bernd@bzed.de> writes:
>> Sometimes, a package requires another package to be installed and
>> configured before it can be installed. In this case, you must specify a
>> Pre-Depends entry for the package.
> "Installed" here means "unpacked," not configured.  There's a pending
> Policy bug to clarify that.

Thanks for the clarification, I fall about that one once a year.

>> We have exactly this case here. lsb_release needs to be configured
>> first.
> No.  dkms doesn't need lsb-release to be configured before it can be
> unpacked.  That's not this case.

 Bernd Zeimetz                            Debian GNU/Linux Developer
 http://bzed.de                                http://www.debian.org
 GPG Fingerprints: 06C8 C9A2 EAAD E37E 5B2C BE93 067A AD04 C93B FF79
                   ECA1 E3F2 8E11 2432 D485 DD95 EB36 171A 6FF9 435F

Reply to: