[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: status of circulars dependencies in unstable

[Bill Allombert]
> Here the list of current circular dependencies:
> * perl perl-modules

Heh, I suspect this one just caused a test upgrade I did of a KDE
desktop from Lenny to Squeeze to fail.

Upgrading perl-modules failed with this error message (in Norwegian,
sorry about that):

  dpkg: Kravproblem hindrer oppsettet av perl-modules:
   perl-modules krever perl (>= 5.10.1-1). Men:
    Versjon av perl på systemet er 5.10.0-19lenny2.
  dpkg: Feil ved behandling av perl-modules (--configure):
   kravproblem - setter ikke opp pakken

This is while trying to upgrade 725 packages.  dpkg is complaining
that perl-modules require perl (>= 5.10.1-1), while only perl version
5.10.0-19lenny2 is available and aptitude end up failing to set up

In the same upgrade, several KDE packages fail to upgrade because of a
missing conflict (#584861), so this is not the only issue left to fix
for upgrades to work, but thought it best to mention it here and ask
if this is caused by the perl<->perl-modules dependency loop or
something else.  Anyone know?

Happy hacking,
Petter Reinholdtsen

Reply to: