[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Xen, Squeeze, and Beyond

Toni Mueller wrote:
> On Sat, 27.02.2010 at 21:59:39 +0100, Tollef Fog Heen <tfheen@err.no> wrote:
>> ]] Faidon Liambotis 
>> | Beyond that, I've also seen filesystem corruption when using live
>> | migration and the filesystem cache hasn't been disabled -- an almost
>> | undocumented directive of libvirt's XML.
>> | 
>> | All in all, I'm wondering how people can call this "stable".
>> I would guess at most people not using live migration and so never
>> hitting those kinds of problems.
> I have not used live migration, either, but unless Michael Tokarev's
> efforts turn out to be fruitful, I'll be out of KVM due to much bigger
> problems than a non-working live migration, and at that point, Xen
> would be the only alternative.

Toni, please understand that it looks like you're the only one on this
planet to hit the issues you describe with kvm.  #569990 and #568293 -
both of them are, well, unreproduceable (I mean the last parts of them).
Seriously, it was quite some time ago when I saw kvm behaving like this
having issues in places where it just works since long time...

I can't do anything with this unless I can reproduce the issues.  Or
maybe you provide access to your system to me.  Or else I'll just mark
the bugs as 'unreproduceable'.

I'm not a developer of qemu or kvm, I don't know much internals, but
I've some pretty good experience in this area (I think I've hit every
kvm's bug ever existed, -- that's why I wished to step in to manage it
in Debian), and I've seen many various problematic situations with it
too -- #kvm @FREENODE had alot of them.

What you describe just does not fit in my mind.  That's the reason of
my quite harsh tone when I replied to bugs mentioned above...  It's
sorta like discovering bugs in cat(1) (lockups, opening wrong files
etc) which worked for many people before...

Please don't get me wrong - I want this mess to be sorted out somehow,
but - in short - I can't believe it unless I'll see it with my own
eyes... ;)

By the way, have you tried to update BIOS and upgrade the CPU you
have?  If memory serves me right, you've Athlon X2 64 4400+, and
maybe that's the problematic one too...  I'll try kvm on my old
Acer Aspice 9300 (circa 2005 or so) with a dual-core Duron, but
I know I've run KVM on it before and it worked just fine...



Reply to: