[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

netatalk: Please avoid accidental linking against libssl [was: GPL-licensed software linked against libssl on buildds!]

Package: netatalk
Version: 2.0.5-2
Severity: important

Holger Levsen:
how about the compromise and doing both, except that for (1) we file the bugs
with severity important?

Hi Jonas,

as recently pointed out on debian-devel [1], the netatalk package is accidently linked against libssl on some arches due to dirty buildd chroots. To avoid this license violation, explicit Build-Conflicts against libssl-dev should be added and only be removed if $DEB_BUILD_OPTIONS contains "openssl".


[1] <http://lists.debian.org/debian-devel/2010/01/msg00354.html>

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (550, 'unstable'), (400, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-trunk-686 (SMP w/1 CPU core)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Reply to: