[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

unused parameters passed to maintainer scripts

Hello developers,

I've done a small research against maintainer scripts from all binary packages
from sid distribution and discovered that some parameters which are passed to
maintainer scripts are not used at all, specifically:

- in-favour <package> <version> (prerm, postinst) - for sure;
- removing <package> <version> (prerm, postinst) - for sure;
- <overwriter> <overwriter-version> (postrm) - most probably, checked only a
part so far.

So, the question: how do people think, is a goal to deprecate&remove these
params in dpkg and policy worthy?

Eugene V. Lyubimkin aka JackYF, JID: jackyf.devel(maildog)gmail.com
C++/Perl developer, Debian Developer

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: