[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#519184: ITP: gribapi -- GRIB decoding/encoding software library

Package: wnpp
Severity: wishlist
Owner: Enrico Zini <enrico@debian.org>

* Package name    : gribapi
  Version         : 1.7.0
  Upstream Author : Enrico Fucile <enrico.fucile@ecmwf.int>
* URL             : http://www.ecmwf.int/products/data/software/grib_api.html
* License         : LGPLv3
  Programming Lang: C
  Description     : GRIB decoding/encoding software library

 The ECMWF GRIB API is an application program interface accessible from
 C and FORTRAN programs developed for encoding and decoding WMO FM-92
 GRIB edition 1 and edition 2 messages.
 ECMWF is the European Centre for Medium-Range Weather Forecasts.

I have already done most of the packaging at:

I have one thing of which I am unsure: upstream does not yet build
shared libraries, but the interface is rather stable and I patch the
sources so that the Debian package does provide them.  The issue is
about the libtool versioning: at the moment I picked 0:0:0 so that
anything upstream may choose in the future will likely be higher;
however, are there better ways to address this?

Other issues left to solve are nothing more than maybe writing a manpage
or two with help2man.



-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Reply to: