[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#511674: ITP: libthread-queue-perl -- Perl module for thread-safe queues

Package: wnpp
Severity: wishlist
Owner: Damyan Ivanov <dmn@debian.org>

[Cc-ed to perl@packages.d.o since this module is in perl-modules]

* Package name    : libthread-queue-perl
  Version         : 2.11
  Upstream Author : Jerry D. Hedden, <jdhedden AT cpan DOT org>
* URL             : http://search.cpan.org/dist/Thread-Queue/
* License         : same as Perl (Artstic or GPL)
  Programming Lang: Perl
  Description     : Perl module for thread-safe queues

  Thread::Queue provides thread-safe FIFO queues that can be accessed
  safely by any number of threads.
  Any data types supported by threads::shared can be passed via queues:
   * Ordinary scalars
   * Array refs
   * Hash refs
   * Scalar refs
   * Objects based on the above
  Ordinary scalars are added to queues as they are.
  If not already thread-shared, the other complex data types will be
  cloned (recursively, if needed, and including any blessings and
  read-only settings) into thread-shared structures before being placed
  onto a queue.


Thread::Queue is now included in perl-modules.

The reason for a package separate from perl-modules is that I need a
version (2.11) newer than the one in perl-modules (2.00, same as in perl
5.8). 2.11 is needed by Padre 0.25 (ITP#492696).

Perl maintainers, please tell me if you want me to hold this package,
for example because you are planning to upgrade Thread::Queue in
perl-modules. Otherwise, please be prepared to add libthread-queue-perl
to Conflicts/Provides list of perl-modules when that is upgraded to
includes a version same or superseding the one in the separate package.

Upgrading only Thread::Queue in perl-modules would also need upgrading
thread::shared because T::Q 2.11 needs t::s 1.21, while perl-modules has
1.14. Separate libthread-shared-perl has 1.21.

This is a complex matter to me so your advice is appreciated.

-- dam

Reply to: