[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFC: adding pre-depends to libpam-modules for lenny

]] Steve Langasek 

(Not wearing any particular hat here)


| Is it ok to make libpam-modules Pre-Depends: debconf (>= 0.5) | debconf-2.0
| for lenny?

Yes, I think this sounds reasonable (and your analysis looks good to me).


| So is it ok to also make libpam-modules Pre-Depends: ${shlibs:Depends} for
| lenny?  For reference, the current shlibs (on i386) are:
|   libc6 (>= 2.7-1), libdb4.6, libpam0g (>=, libselinux1 (>= 2.0.59)
| Again, these are all already transitively essential, so the main concern is
| whether further restricting the unpack order will cause any dependency
| loops, which I don't believe it will.

Testing or manually verifying that there are no loops is probably wise,
but otherwise this looks fine too.

| If y'all agree to this change, I can knock out the implementation within a
| couple of days and get another RC bug off the list - then I just have to
| accept the beatings from Christian for the implied addition of a new debconf
| template this late in the lenny freeze... :)

Just send him some cheese and red wine and he'll be happy. :-)

Tollef Fog Heen
UNIX is user friendly, it's just picky about who its friends are

Reply to: