[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Why was php5-sqlite3 removed from lenny?

On Tue, Nov 11, 2008 at 4:51 PM, Julien Danjou <acid@debian.org> wrote:
> I use sqlite3 with PHP 5 and PDO from lenny, and it works.

OK, I've find it, it's in "php5-sqlite" package.  I didn't expect
to find it there because AFAIK that package used to have support
for sqlite version 2... I think it would be nice to add something like
"This package allows you to access SQLite3 databases".
That way, people (like me) will find it when doing
"apt-cache search sqlite3 php".

An now, another question: I know I can use PDO to access sqlite3
databases, but, why not keeping the old sqlite3_* functions,
to avoid having to change all the existing code?


Juan Cespedes

Reply to: