[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Minor bobble in etch->lenny upgrade

Just upgraded an old etch box to lenny via aptitude, ran into the
following minor problem:

(Reading database ... 22081 files and directories currently installed.)
Preparing to replace mount 2.12r-19etch1 (using .../mount_2.13.1.1-1_i386.deb) ...
You have NFS mount points currently mounted, and this version of mount
requires that nfs-common be upgraded before NFS mounts will work.

Aborting install.
dpkg: error processing /var/cache/apt/archives/mount_2.13.1.1-1_i386.deb (--unpack):
 subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Press return to continue.

I've no idea whether or not there's anyway to make this happen without
user intervention; I just unmounted the NFS disk and restarted aptitude,
which then proceeded without problem.


Reply to: