[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libpqxx in NEW fixes RC bug (was: Re: Lenny frozen)

Adeodato Simó wrote:
> * Eugene V. Lyubimkin [Tue, 29 Jul 2008 18:56:37 +0300]:
>> For example, new version of 'libpqxx' package is now in NEW, and it
>> fixes RC bug (serious, recently appeared), but contains another changes.
> I don't see any mention in the changelog for 2.6.9-7 of a RC bug. Which
> one it is?
Yes, 2.6.9-7 was uploaded before this bug was filed to BTS as a bug. I am saying about
#492693 and #492880 (merged into one). So the relevant changelog entry (no. 3 in the
changelog) doesn't contain "closes" and I will close these bugs after 2.6.9-7 enters unstable.

Possibly dangerous change in recent upload is the removing of static library from
development package.

And, at last, I've just prepared 2.6.9-8 with the tiny fix to make upgrade from 2.6.9-6
easier. I suppose my sponsor will upload it in a few days.
Proposed changelog between 2.6.9-7 and 2.6.9-8:

diff -u libpqxx-2.6.9/debian/changelog libpqxx-2.6.9/debian/changelog
--- libpqxx-2.6.9/debian/changelog
+++ libpqxx-2.6.9/debian/changelog
@@ -1,3 +1,11 @@
+libpqxx (2.6.9-8) unstable; urgency=low
+  * debian/control:
+    - Bumped 'Conflicts' and 'Replaces' in libpqxx-doc to (<< 2.6.9-7) due to
+      broken build system of 2.6.9-6.
+ -- Eugene V. Lyubimkin <jackyf.devel@gmail.com>  Tue, 29 Jul 2008 23:40:12 +0300
 libpqxx (2.6.9-7) unstable; urgency=low

   * Introduced debug package: libpqxx2.6.9ldbl-dbg.
diff -u libpqxx-2.6.9/debian/control libpqxx-2.6.9/debian/control
--- libpqxx-2.6.9/debian/control
+++ libpqxx-2.6.9/debian/control
@@ -23,8 +23,8 @@
 Section: doc
 Architecture: all
 Suggests: libpqxx-dev (>= ${binary:Version})
-Conflicts: libpqxx-dev (<< 2.6.9-6)
-Replaces: libpqxx-dev (<< 2.6.9-6)
+Conflicts: libpqxx-dev (<< 2.6.9-7)
+Replaces: libpqxx-dev (<< 2.6.9-7)
 Description: C++ library to connect to PostgreSQL (documentation)
  C++ library to enable user programs to communicate with
  the PostgreSQL database back-end.

I am kindly requesting for freeze exception for libpqxx 2.6.9-7 and 2.6.9-8.
I don't intend to make further uploads of libpqxx before Lenny release.

Eugene V. Lyubimkin aka JackYF, Ukrainian C++ developer.

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: