[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel 2.6.25 broke iPod support for me, but who to bug?

On Fri, Jul 11, 2008 at 09:11:57PM -0400, James Vega wrote:
> On Sat, Jul 12, 2008 at 02:19:58AM +0200, Frank Lichtenheld wrote:
> > Hi.
> > 
> > While testing some updates to my gtkpod/libgpod packages I noticed that
> > I couldn't actually play any songs anymore from my iPod. Which worked
> > fine some weeks ago.
> > 
> > I traced the error back to a change in kernel 2.6.25: Apparently vfat
> > file system can now become case sensitive in some cases
> > ("FAT: utf8 is not a recommended IO charset for FAT filesystems,
> > filesystem will be case sensitive!")
> Are you sure this is a kernel change and not just a change in your
> kernel config?  I brought up what seems to be the same (or at least
> closely related) problem 4 years ago on lkml[0].

To be precise the upgrade from the current (i.e. today) 2.6.24 testing
kernel to the current 2.6.25 unstable kernel causes the problem.

So yeah, both code and config changed I guess.

Frank Lichtenheld <djpig@debian.org>
www: http://www.djpig.de/

Reply to: