[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#481973: ITP: libiptables-parse-perl -- Perl extension for parsing iptables firewall rulesets


> The package psad contains a file /usr/lib/perl5/IPTables/Parse.pm.
> (http://www.cipherdyne.org/modules/ also mentions ".. provides ..
> modules used by the psad, ...")
> This potential clash should be sorted out before an upload.

As a matter of fact, all packages from cipherdyne are being packaged
to avoid conflicts between psad, fwsnort and fwknop.

Talking with Daniel Gubser (psad maintainer), and Michael Rash 
(upstream author), we decided the best way to integrate the three main
packages, was to create : 

- libiptables-parse-perl
- libiptables-chainmgr-perl

So, right now, in my repository, I have :

- a rebuilt psad with new dependencies,
- fwsnort,
- libiptables-parse-perl (IPTables::Parse),
- libiptables-chainmgr-perl (IPTables::ChainMgr),
- fwknop under development.

Daniel is fairly busy, but I am working with M. Rash to get something 
nice until he has the time to take a look.

Franck Joncourt.

Reply to: