[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sorting out mail-transport-agent mess

On Fri, May 16, 2008 at 02:10:39AM +0200, Eugeniy Meshcheryakov wrote:
> 15 травня 2008 о 16:24 -0700 Steve Langasek написав(-ла):
> > > What concerns me about this approach is that it could easilly end up with 
> > > dist-upgrades swapping out users mail systems without warning. I would 
> > > consider such behaviour unacceptable as it could easilly cause mail loss 
> > 
> > Er, no, that wouldn't happen.  As long as packages correctly depend on
> > default-mta | mail-transport-agent, this will have no impact on upgrades.
> > 
> This can happen if user has 'default-mta' package installed, and it
> changes (if it is done like with 'gcc' package now).

What if default-mta itself depend on the current default (exim4) |
mail-transport-agent? Then future changes to default-mta would not
affect installed users.


Package: something-that-needs-an-mta
Depends: default-mta | mail-transport-agent

Package: default-mta
Depends: exim4-daemon-light | mail-transport-agent

Hamish Moffatt VK3SB <hamish@debian.org> <hamish@cloud.net.au>

Reply to: