[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ${devlibs:Depends} results in libstdc++6-4.1-dev

On Thu, 17 Apr 2008, Julien Cristau wrote:

when trying to update libgenome-1.3-1-dev I noticed that the variable
${devlibs:Depends} is turned into a dependency from a libstdc++6 which
is shipped with gcc-4.1 instead of using libstdc++6-4.2-dev or even
libstdc++6-4.3-dev.  Quoting from my *.build log in an up to date
pbuilder environment:

Sounds like d-shlibs is broken.  See #374049.

Hmmm, this sounds very close to my problem and thus I keep the bug
in CC (maintainer and reporter please se [1] for a full description
of the problem), but if I try

  $ apt-cache show libstdc++6-dev | grep Version
  Version: 3.4.6-6

I get even at these days 3.4.6 (which is strange anyway) but which gives
no explanation for the 4.1 dependency I faced.

This is simply strange.

Kind regards


[1] http://lists.debian.org/debian-devel/2008/04/msg00559.html

Reply to: