[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Rejected: epcr_2.3.9-1.dsc: sha1 check failed

Roberto C. Sánchez wrote, Thursday, April 17, 2008 2:24 AM

On Wed, Apr 16, 2008 at 04:25:46PM +0100, Matthew Johnson wrote:
do you have updated devscripts? debsign signs the dsc then updates the
md5 hash in the changes before signing that. It needs to update the sha
checks as well. The latest devscripts does.

Will the devscripts in stable be updated to handle this?  If so, when?
If not, why not?

(If you're looking for an answer from the maintainers of a package it's probably safer to ask them directly rather than assuming they read every post on debian-devel; admittedly several of us do, but... :-)

I'm not convinced it meets the SRM team's criteria for a stable update, as laid out in http://release.debian.org/stable/4.0/4.0r3/ et al.

2.10.25 should migrate to testing over the weekend, so hopefully a bpo package won't be too much longer. In the meantime it's fairly easy to backport yourself, as several people have already done, or simply copy the new script over from an unstable machine. Other than the update for the new .changes file format, there have been relatively little changes to debsign since the version in etch, and those have all been bugfixes.


Reply to: