[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: swfdec0.6 buildd failure

On Mon, 2008-03-03 at 21:52 +0100, Jiří Paleček wrote:
> Hello,
> I was looking at the swfdec0.6 package and wondered why it is unavailable  
> on almost all architecture.

It only exists in experimental - packages in experimental *might* be
autobuilt but the only way to be sure is to get the package in a fit
state for unstable.

>  So I looked at the build logs and they  
> (almost) fail in a quite strange way. It seems apt installed a broken set  
> of packages (even though a package set satisfying the build-dependencies  
> was -probably- available).

Probably? Are you able to build it using pbuilder yourself?

> Is this a bug in APT?

Probably not.

It looks more like a feature of experimental, most of the logs I saw
include this error:

libglib2.0-dev: Depends: libglib2.0-0 (= 2.14.6-1) but 2.15.5-1 is to be

i.e. one of your dependencies is also in experimental and therefore
builds of your package try to use this experimental version which then
fails because experimental is not a complete distribution.


Neil Williams

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: