Re: Standardisation of the name of the patching targets included in debian/rules.
On Sun, Feb 03, 2008 at 08:14:35PM +0100, Stefano Zacchiroli wrote:
> On Sun, Feb 03, 2008 at 11:10:41AM +0100, Martin Quinson wrote:
> > I find personnaly patch/unpatch more easy to understand, but YMMV...
> I think (hope) that no one will be able to find a reason why the two
> target should *not* be called "patch" / "unpatch". They are IMO the only
> 2 that people will be able to guess out of the blue.
> So please go for patch/unpatch.
An unpatch target might be problematic. There're packages with patches
that touch the upstream Makefile, and calling 'make unpatch' before
'make clean' can break things; of course the clean target can depend on
patch, but this seems to complicate things. Why not simply do the
unpatch in the clean target?
This is what I use in packages I maintain:
patch: deb-checkdir patch-stamp
for i in `ls -1 debian/diff/*.diff || :`; do \
patch -p1 <$$i || exit 1; \
clean: deb-checkdir deb-checkuid
$(MAKE) clean $(OPTS)
test ! -e patch-stamp || \
for i in `ls -1r debian/diff/*.diff || :`; do patch -p1 -R <$$i; done
rm -f patch-stamp [...]