[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Injecting versions of build-deps in the deps

On Fri, 07 Dec 2007, Loïc Minier wrote:
> On Fri, Dec 07, 2007, Raphael Hertzog wrote:
> > libgtk-x11-2.0.so.0 libgtk2.0-0 #MINVER#
> > * Devel-Package: libgtk2.0-dev
> >  symbol@Base 2.8.0
> >  ...
> > How does that sound ?
>  Sounds like a good start!  Perhaps the injection should be explicitely
>  requested with:
>   * UseBuildDepVersionAsMinVer: yes
>  or the field could be named to reflect that it's used for bdeps:
>   Build-Depends-Package: libgtk2.0-dev

Yeah, I settled on "Build-Depends-Package". I implemented this. You can
test with this package:

I'd like some more feedback that this is considered a good idea before I
push this on dpkg's git repo. But otherwise it seems to work quite well

>    So it only leaves dealing with multiple bdeps: I suppose they could
>  all be copied over and will generate the same warning that the
>  duplicate build-dep.

It will just take the biggest minimal version required.

Raphaël Hertzog

Le best-seller français mis à jour pour Debian Etch :

Reply to: