[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#454162: libxine1-plugins: should not depend on libxine1-gnome

Philippe Cloutier <chealer@gmail.com> writes:

>> This bug is now about that all plugins are installed by default,
>> dragging in too many dependencies at install/upgrade time. I have the
>> following compromise in mind, which I first want to be commented on
>> before I do the follwing changes:
>> a) Let's introduce 2 meta packages: libxine1-all-plugins, which depends on
>> all binary packages including libxine1-gnome, and another one
>> libxine1-common-plugins, which depends on all packages except
>> libxine1-gnome.
> I'm not sure about a) ; how would these meta packages be used?

Like this:

Package: libxine1
Architecture: i386
Source: xine-lib
Version: 1.1.8-4
Depends: libc6 (>= 2.6.1-1), libxine1-bin (= 1.1.8-4), libfreetype6 (>= 2.3.5), libxine1-common-plugins (= 1.1.8-4) | libxine1-misc-plugins (= 1.1.8-4), zlib1g (>= 1:
Recommends: libxine1-doc | libxine-doc, libxine1-ffmpeg
Suggests: gxine, xine-ui
Description: the xine video/media player library, binary files
 This is the xine media player library (libxine).

libxine1-common-plugins would depend on libxine1-x and libxine1-mpeg.

Reinhard Tartler, KeyID 945348A4

Reply to: