[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#454162: libxine1-plugins: should not depend on libxine1-gnome

Quoting Reinhard Tartler <siretart@tauware.de>:
a) Let's introduce 2 meta packages: libxine1-all-plugins, which depends on
all binary packages including libxine1-gnome, and another one
libxine1-common-plugins, which depends on all packages except

b) Additionally, the libxine1 package gets versioned conflicts against
all gnome/gtk2 related frontends in etch.

I'm personally not too happy with b), since I'd expect those frontends
to depend on the libgnomevfs2-0 anyways. OTOH, they don't depend on
libxine1-gnome either, so they will suffer in a lacking xine gnomevfs
and esd plugin. I'm listing it here because it has been suggested to me,
and while I'm not too happy with it, I'm not too strong on this point

I am a bit confused by this. Why don't you simple report bugs on those packages to update the dependencies because of this transition instead of inventing numerous work-arounds? To an outsider, the coordinated change will look as Debian working as a whole, not seperate individual maintainers that cannot cooperate. After all, those suggestion above are only done to save some minutes for each frontend maintainer.
I'd say that communication is the best solution, here.


Reply to: