[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#416841: Need help with MySQL upgrade tests on 2.4 kernel

On Tue, Apr 10, 2007 at 10:39:10AM +0200, Christian Hammers wrote:

> On 2007-04-09 Steve Langasek wrote:
> > On Mon, Apr 09, 2007 at 01:28:18PM +0200, Christian Hammers wrote:
> > > > Mmm, guess I wasn't clear -- I mean that there's no point in trying to work
> > > > on this bug, because lenny *as a whole* will not support 2.4 kernels.  (the
> > > > glibc maintainers are eager to drop LinuxThreads support, which means lenny
> > > > will stop supporting threading on 2.4 within days/weeks of the etch
> > > > release.)

> > > What I feared was the upgrade process itself. I guess that mysql and the
> > > new 2.6 kernel will get installed in the same "apt-get dist-upgrade" run
> > > and thus if mysql-server-5.0 hangs and the user presses ctrl-c he is left
> > > with a half broken system.

> > It *doesn't* *matter*.  Running etch with a 2.4 kernel is not officially
> > supported;

> I talk about the upgrade from *sarge* to etch!
> The bug report was against the etch version of mysql

No, it wasn't; it was reported against a version of mysql that was only in

Now if there's a reason to believe it also applies to the etch version of
the package, then ok; but that's not the version it was filed against.

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon@debian.org                                   http://www.debian.org/

Reply to: