[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#416841: Need help with MySQL upgrade tests on 2.4 kernel

On 2007-04-07 Steve Langasek wrote:
> On Sat, Apr 07, 2007 at 03:39:11PM -0400, Lennart Sorensen wrote:
> > On Sat, Apr 07, 2007 at 12:28:13PM -0700, Steve Langasek wrote:
> > > Isn't this only reported against the version in sid, which is not
> > > included in etch?
> > > Etch is the last Debian release that supports upgrades from 2.4
> > > kernels. Lenny will not run on a 2.4 kernel.  Perhaps the users should
> > > just upgrade?
> > OK, I will grab the sid version of mysql and try it.  And I will use the
> > 2.4.27 kernel too.
> Mmm, guess I wasn't clear -- I mean that there's no point in trying to work
> on this bug, because lenny *as a whole* will not support 2.4 kernels.  (the
> glibc maintainers are eager to drop LinuxThreads support, which means lenny
> will stop supporting threading on 2.4 within days/weeks of the etch
> release.)

What I feared was the upgrade process itself. I guess that mysql and the
new 2.6 kernel will get installed in the same "apt-get dist-upgrade" run
and thus if mysql-server-5.0 hangs and the user presses ctrl-c he is left
with a half broken system.

Or is there some mechanism that tells the user first to upgrade to a 2.6
kernel then reboot and then update the rest of the packages?



Attachment: signature.asc
Description: PGP signature

Reply to: