[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Not depending on shlibs because of plugins?



On Fri, Jan 05, 2007 at 07:53:35PM +0100, Christoph Berg <myon@debian.org> wrote:
> Re: Andreas Metzler 2007-01-05 <k9i274-cf4.ln1@argenau.downhill.at.eu.org>
> > Which does not seem to be properly translateable into a valid single 
> > fasel|(foo | bar, blah) Depends relation[1].
> 
> It won't work if a plugin needs more than one dependency, right.
> 
> > You could move the plugin's additional dependencies into Recommends,
> > using "dpkg-shlibdeps -vRecommends" but as the program would not work
> > without any plugin packaging them separately indeed seems to be the
> > sanest way.
> 
> -p is actually more interesting here:
> 
> $dpkg-shlibdeps -pmysql -edebian/libyada4/usr/lib/libyada_mysql.so.4
> $dpkg-shlibdeps -ppostgres -edebian/libyada4/usr/lib/libyada_pgsql.so.4
> $dpkg-shlibdeps -psqlite -edebian/libyada4/usr/lib/libyada_sqlite3.so.4
> $cat debian/substvars
> mysql:Depends=libc6 (>= 2.3.5-1), libmysqlclient15off (>= 5.0.24-2)
> postgres:Depends=libc6 (>= 2.3.5-1), libpq4 (>= 8.1.4)
> sqlite:Depends=libc6 (>= 2.3.5-1), libsqlite3-0 (>= 3.3.8)
> 
> Then remove the libc6 parts and use
> Depends: ${shlibs:Depends}, ${mysql:Depends} | ${postgres:Depends} | ${sqlite:Depends}

Which may end up as libc6 (>= 2.3.5-1), libmysqlclient15off (>=
5.0.24-2) | libc6 (>= 2.3.5-1), libpq4 (>= 8.1.4) | libc6 (>= 2.3.5-1),
libsqlite3-0 (>= 3.3.8)

which is libc AND (libmysql or libc) AND (libpq or libc) AND libsqlite3.

Not exactly what you'd like...

Mike



Reply to: