[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: preconfiguration fails, versioned dependency not satisfied

Steve Langasek wrote:
> A pre-depend is not sufficient to ensure a package's availability when
> apt-preconfigure is run.

This is true, with the exception of dependencies on debconf itself.
dpkg-preconfigure should skip over packages that depend or pre-depend on
a version of debconf newer than the version currently installed, thus
deferring the precomfiguration to the postinst. This skipping is
actually done by apt-extracttemplates.

If it's not working, you may have hit a bug in apt. I did just look at
the code in apt-extracttemplates and it's still there, at least.

see shy jo

Attachment: signature.asc
Description: Digital signature

Reply to: